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ALLIANT
Adding Image Service (WMS) to MicroStation V8i
1) Assign a Geographic Coordinate System to the Drawing

a) Click Tools>Geographic>Select Geographic Coordinate System.

@& ~ WETL DELN INP vl 4 v ZZeowr = 2 v Qo v ey @4

File Edit Element Settings Tools Utilites Workspace GEOPAK Window Help Alliant MnDOTMenu

Tasks W |/ Attributes

# Tasks v Prmary
Standard

i1 M & L0 [
X 1o P D s 5 X Main
€ Roundabouts v Tasks

Civil Geometry Animation

Data Acquisition Base Geometry
& Civil Workflows Cots
Civil Accudraw
Print Preparation
Change Tracking
! Drawing L Civil Geometry
8 /A N N Clash Detection
Q AN
{ Coordinate Systems

Curves
w
Custom Linestyles

vy v Y v wwywwwwow

E ) D N 12 Database

R J J J &3 o 5 % Data Acquisition

T D D ! 2R [}({ Detailing Symbols
> Dimensions

A A BABc 2 A 4
v A2 ¥ ABC A* A
AL

AL Al

A B g AN st Geographic
S AN Coue
N A O Levels

Select Geographic Coordinate System
Global Positioning System (GPS)
Export Google Earth (KML) File
Manipulate Capture Google Earth image

i ot [y e
F ]L | TA 2 HE ML Measure Define Placemark Monument

Redv S8

(3 Drawing Composition Synchronize Google Earth View

Multi-ines Follow Google Earth View

Parametrics Google Earth Settings
Patterning

Point Cloud

Play Camera Animation in Google Earth

IO 10 |0 N [ [ |8 (W N )=

Open Location in Google Maps

Project Navigation

U BE®@!

Open as ToolBox
Properties
Element Selection v

v v YT YTYTYTYTTYTYTYTYTY YTy v

Raster

b) The following dialogue box will appear. It will be blank or it might already contain a geographic
coordinate system. For this series of screen images, MnDOT’s Ramsey County US Foot is the
desired coordinate system:

P Geographic Coordinate System - X

Current Geographic Coordinate System

Name: RamseyMN-F
Descrniption: Minnesota DOT: Ramsey County, US Foot
Source: Minnesota Dept. of Transportation

733 Marquette Ave Ste 700 612.758.3080 MAIN -
Minneapolis, MN 55402 612.758.3099 FAX www.alliant-inc.com



WMS Aerial to Microstation and Printing
CADD Committee

March 9, 2020

Page 2

c) Click on ‘From Library’ and the ‘Select Geographic Coordinate System’ window appears.

M=

space GEOPAK Window Help Alliant MnDOTMenu

2 Qo vy @-O-eE-8-EB-a-2-RQ @

D &2l iR

lefault
v ARQRHYHE

Current Geographic Coordinate System
Name: RamseyMN-F

Description: Minnesota DOT: Ramsey County, US Foot
Source: Minnesota Dept. of Transportation

B4 Select Geographic Coordinate System

Library Search

LakeNorthShoreMN-F - Minnesota C A
dsNoMN-F - Minnes
dsSoMN-F - Minnes

)OT: LyonC

esota DOT:?

F-N ota T:Ma
\-F - Minnesota DOT: Martin

F - Minnesota DOT: Mcl

IN-F - Minnesol
NormanMN-F - M
OlmstedMN

esota DOT: f
PineMN-F - Minnesota DOT: Pine Cc
PipestoneMN-F - Minnesota DOT P
PolkMN-F - Minnesota DOT: Polk Cc
PopeMN-F - Minnesota DOT: Pope |
RedL MN-F - Minnesota DOT: Re
dMN-F - Minnesota DOT: R
MN-F - Minnesota DOT: Rer
RiceMN-F - Minnesota DOT: Rice C«
RockMN-F - Minnesota DOT: Rock ( v
< >

Coordinate System

Ellipsoid

d) Select the appropriate geographic coordinate system for the project. Alliant has prepared a
favorites folder that includes commonly used coordinate systems. Click OK.

L 3]
=t {84 e s
i gl o S
Current Geographic Coordinate System
Name: RamseyMN-F
Description: Minnesota DOT: Ramsey County, US Foot
Source: Minnesota Dept. of Transportation

e) Close the Geographic Coordinate System window or move to the side.
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2) Create a new WMS configuration file with the Raster Manager
dialogue box.

a) Click the ‘Raster Manager’ icon. Select the ‘File’ dropdown and choose
File>New>WMS.

ves'\DWE'\Rain Gauge Locs [2D - V8 DGN] - Power GEOPAK Vi (SELECTseries

a-0 @@ -2 h @ -0wy
MnDOT!
Bl Raster Manager : 0 of O listed — X
File | Edit View Display Settings Utilities
L= > -
New B WMS... R, R T
Attach * |8 Image Server
Detach
[l Detach A Description [
Il Reload
Save As
Import »
Baich Convert

b) Inthe ‘WMS Map Editor’ window, enter
‘https://imageserver.gisdata.mn.gov/cgi-bin/wms’
and press enter.

B \WMS Map Editor - Creating new map = O X ‘
ij - 1
| ips [fimages Servers
Available Layers Seflings Preview
] I_\«1nGeo W MS service (aerial photography) Sarver -
4@ Regional
- l& Twin Cities metro Tithe MnGeo WMS service (aenal photography)
& @ Statewide JRL hittps:/fimageserver.gisdata mn.gov/cgi-bil
Map Definition -
Layers
Range Method Use range limits
B Map Range Limits
Layer Ranges Use intersection of ranges of layers
Model Coordinate System Use useful range as limit

¢) Inthe ‘WMS Map Editor’ window, click on the ‘Servers’ button in the upper right. A list of servers
appears. Select the service desired, make sure the ‘Connection’ tab lists it as ‘connected’ and
not ‘error’ or blank, click ‘OK’.
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h Servers Manager

@XS R

« URL

* hitps./imageserver gisdata. mn.gov

¢ http://gecintimic.state.mn.us/cgi-binfwms

¢ http:[fgeointImic state mn us/cgi-binfwmsll

© hitp:[igecintmic.statemn.us/cgrbinfwmsz

© http:[imndotgis dot state mn us/egis12/services/BA, efror

grbinfwms

Connection

connected

Server »
Title MnGeo WMS service (aerial phi
URL hitps:/fimageserver.gisdata. mn,

d) Inthe ‘WMS Map Editor’ window, browse the ‘Available Layers’ to select the aerial photography
needed for the project. After selecting the aerial photographs needed, click ‘Add to map’. The
selected layer, or layers, will appear in the lower left of the ‘WMS Map Editor’ window.

B4 WMS Map Editor - Creating new map
N

|htps f/imageserver gisdata mn gov/cgrbinwms

- a X ‘

~ Servers

Available Layers

@ MnGeo WMS service (aetial photography)
@ @ Regional
=@ Twin Cities metio
@ 1997 bw 7-county
@ 2000 bw -county
@ 2004 color MSP
@ 2006 color 7-county (parial)
@ 2006 color Ramsey
® 2008 color Twin Cities
@ 2010 cir F-county
@ 2010 cir Dakota
@ 2070 cir north counties
@ 2010 cir Scott
@ 2010 color 7-county
@ 2010 color Dakota
® 2010 colornorth counties.
@ 2010 color Scon
@ 201 cirRice
@ 2011 color Rice
@ 2012 color Twin Cities
@ 2013 cirCarver
@ 2013 cir Dakota
® 2013 cir Scott
@ 2013 color Carver
@ 2013 color Dakota
@ 2013 color Scon
@ 2013 Washington

Add to msp

Map Layers

Layer Tite LayerName Style Tle  StyleNa.. Opaque 5
<
>

Seftings Preview
Server
Title
URL
Map Definition
Layers
Range Method
/5l Map Range Limits
Layer Ranges
Model Coordinate System
Map Coordinste System
B Projected Coordinates

Maximum Y

-

MnGeo WMS service (aerial photography)
hups /fimageserver.gisdata.mn.gov/cgi-bif

~

Use range limits.

Use infersection of ranges of layers
Use useful range as limit
Use useful range as limit

5011687.6525409762
522730.42466200574
4956641.0644268012
416896 7511358289

45715°30.0000"N
92°43'00.0000"W
44°45'30.0000"N
94°03'00.0000"W

EPSG:26915
image/jpeg
hitps /fimageserver gisdata mn gov/cgi-bi{
11
True

-
metl6

2016 color 7-county
Twin Cities metro
True

e) Click Save in the lower right of the ‘WMS Map Editor’ window. Select “No Wizard” and click ‘OK’.
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B WMS Map Editor - Creating new map - | %
—
hcaa
| itps /imageserver gisdata mn gov/cgi binfwms <1 [ Sevems
Available Layers Setings  Preview Ready)
@ MnGeo WMS service {aerial photography) — -~
%@ Regional
S @ Twin Cities metro Title MnGeo WMS service (aerial photography)
® 1937 bw 7-county URL hitps//imageserver gisdata mn_gov/cgi-bif
@ 2000 bw T-county N
@ 2004 color MSP Map: Definition,
@ 2006 color 7-county (partialy Layers met16
P 2006 color Ramsey Range Method Use range limits
@ 2008 color Twin Cities S Map Range Limits
2 Layer R Use intersection of ranges of layers
@ 2010 cir 7-county ayer Ranges ge: '
@ 2010 cir Dakota Model Coordinate System Use useful range as limit
@ 2010 ci north couties Map Coordinate System Use useful range as limit
@ 2010 cir Scott B Projected Coordinates:
@ 2010 color 7-count 6525409762
@ NID:oImDake’: & Selecta Wizard X D42466200574
@ 2010 color north counties 110644268012
@ 2010 color Scott Document Creation Wizards. 57511358289
@ 2011 cirRice oK
@ 2011 color Rice 30.0000°N
® 2012 color Twin Cies ke ‘ 0 0000°W
@ 2013 cir Carvar NoWizard  Advanced 30.0000°N
@ 2013 cir Dakota Wizard 00.0000"W
@ 2013 cir Scot 26915
@ 2013 color Carver fipeg
@ 2013 color Dakota [(IMake this wizard the defauit fimageserver gisdata mn.gov/cgi-bif
@ 2013 color Scott .
P 2013 Washington Transparent True
@ 2016 cir -county
-
@ 2016 color 7-county Selected Lmyer,
B I scicwide] Neme metl6
Style <Server Default>
Title 2016 color 7-county
Parent Twin Cities metro
Opagque True
Map Layers
Layer Title Layer Name Style Tite  StyleNa..  Opaque o
2016 color 7-county  metl§ True
<
x
Save and Aach. Concel

f) A ‘New WMS file’ window appears with the default save location as the original file folder.
Change location if necessary and click ‘save’.

Mew WMS file W%
General
Folder i Save
= == Cancel
Document
Name: Rain Gauge Locs.awms | -

Description: [ Rain Gauge Locs |

File Name: | Rain Gauge Locs.owms |
Format: XWmMS Format...
Application: Department:

<none> A <nonea> w~

3) Attach WMS file within the Raster Manager Dialogue box

a) Click on the ‘Raster Manager’ and select File>Attach>WMS.
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“Rain Gauge Locs [2D - VB DGN] - Power GEOPAK V3i (SELECTseries 2)
rEle-a-a-2-h-@ -0 Rl

‘Mer  File | Edit View Display Settings Utilities

New b omm R EIRm B0
Attach * ‘& Raster. ’
Detach &4 WMS...
Detach Al } FromImage Server... | Description
Reload 4 ECWP Image Server..
Save As
Import k
Batch Convert
< »
1]2]3]4[s]e|7]e & @ Tt [] Transparency i

b) Inthe ‘Attach Raster Reference File’ dialogue box, select the previously created WMS
configuration file (ending in .xwms). Click OK.

# Attach Raster Reference File X
elect

Documents
Folder | [ DWB " Bl=EE g

5 il

Name
v Rain Gauge Locs

- e

b 4

£ >

Application: All Applications e

Add Remaove

Selected Documents, check mark for read-only

Name

e

c) Verify under the ‘Geometry’ tab that the option for ‘Inherit GeoCS from model’ is set to ‘Not
Inherited’ and click ‘Attach’.
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B8 Raster Attachment Options - m} X
] Attachments
B c\pw_working\projectwise\alliant,dms98987\Rain Gauge Locs xwms

General »~
Level WETL DELN INP

Color | K

Line Style 1 eowr

Weight H 2

Class Primary

Priority 32768

Image ~
Logical Name

Description

Geometry -~
Geo Priority Raster Header

Inherit GeoCS from Model Not Inhernited

Color v
Display Print -
Extended -
Conc

d) The WMS Aerial photography should be successfully placed in the drawing per the appropriate

geographic coordinate system for the project.

" & - wen

Tasks

o Tass

CEE

Element Selection vaix

Me-a0 § .

celnie v M4 v Teowy Z 2 v B ovaun MO Ko @ @A R @ DU R
Eh [0 Eerent fetings Took Uiktes Wodsoace GEOPAX Window el At MhOOTMnu

¥ X View 1, et

- [0 owmavm =% J1[2]]o]s]s] ]

cQnc AR RBYO DL NG

=
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4) Printing with Images from a WMS Server in Microstation

a) Prepare your area to print, with either a fence or setting up the view. Select ‘Print’ from
the ‘File’ dropdown menu.

BOBE S

: @ v WETL DELN INP

B pw:\\Alliant-FS2.alliant-inc.com:projectwise\Documents\Projects\2018\180051\DESI(

vl 4 v Zeowy = 2 v Qo v &

‘Elo ‘ Edit Element Settings Tools Utilities Workspace GEOPAK Window H

T;'_) New...

* Open.

Close
Save

Update Server Copy
Refresh Local Copy

Save As...

Compress

Saye Settings
Item Browser
Project Explorer
References
Raster Manager
Point Clouds
Models

Publish i-model. .
Import

Export

Print Preview

Cri+F

?.‘il Print...

|4z Print Organizer

Associate..

Dranartice

b) In the ‘Print’ window, set the ‘Area:’ in the General Settings section to the desired choice.
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B Print (MnDOT-pdf.pltcfg) — X
File Settings Hesymbolization
1 1 5= i
@Y HED ‘
General Settings
Wiew:
Color:
Printer and Paper Size
Bentley driver *| Q
Paper] Roll - 36" x 60" -
Paper size: 60000 36,000 in
Landscape ¥ Create plot file ~
Show design in preview
Print Scale and Position
Scale: | 128.6357 g 1 in. (papear) to 128.6357 ' (design)
Size: 56738 (36000 |in. (1 Maximize Rotation: None ¥
Ongin: | 1.631 0.000 in. Auto-center
Print Resymbaolization
Pen table:  c\pw_working\projectwmse\alliantidms4808 Nalliant_bw tbl qx
Design script: q x
¢) Inthe ‘Print’ window, select File>'Select Bentley Driver’
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d) Click the dropdown menu for the folder displayed at the top of the ‘Select Printer Driver

File Settings Resymbolization
Open Print Definition File..
Save Print Definition File..

Configure Windows Printer
Preview
Print..

Select Windows Printer

sterized

| Select Bentley Driver

Edit Printer Driver Configuration
Reload Printer Dniver Configuration

Exit

2] Full

»

Totalarea: 17x11in
Landscape ¥

Send to printer ¥

Configuration File’ menu. Navigate to
Projects\WorkspaceV8i\Standards\MNDOT_20180323\DOT_MICRO\pltcfg

B Print \\ALLIANT-US1\C6004ex Transportation (printer.pltcfg)

Show design in preview

kY

Bt Select Printer Driver Configuration File

Select

Folder

o plcfg

| Alliant FrojectWise / ALLIANT-INC\dbauer
=" Employee Resources
= Projects
= WorkspaceVBi
' Standards
(" MNDOT_20180323
' DOT_MICRO
£ pidg

|v e plEE el

() ) MnDOT-printer11Z17 (2).pltcfg
[ ) MnDOT-printer11inz17in.pltcfg
20 MnDOT-printer.pltcfg

[ Y MnDOT-pdt pltcfg

[0 Y MnDOT-pdf-wms.pltcfg

(] Y MnDOT-pdi-NoLayers.pltcfg

Address:

MnDOT-printer11Z...
MnDOT-printer1lin...
MnDOT-printer.pltc...

MnDOT-pdf. pltcfg

MnDOT-pdf-wms.p...
MnDOT-pdf-NolLay...

MnDOT-printer11Z...
MnDOT-printer1lin...
MnDOT-printer.pltc...

MnDOT-pdf pltcfg

MnDOT-pdf-wms.p...
MnDOT-pdf-NoLay...

73491
73491
73491
73491
73491
73491

.pw \\Alliant-FS2.alliant-inc.com:projectwise\Documents|\Projects\WorkspaceVai\Standards\MNDOT_20180323\DOT_MICRO\pitcfg),

Description:

File Name:

Application: All Applications

Extension:

[CJ open document as read-only

Printer Driver Configuration Files [*.pitcfg;=.pit]

e) Select MnDOT-pdf-wms.pltcfg and click ‘Open’. A warning might appear “Document MnDOT -pdf-
wms.pltcfg is read only. Would you like to open it anyway?” Click ‘Yes'.
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B Select Printer Driver Configuration File X
Select
Folder
= pidg em =EIR
g .l 2
Document
Name Description File Name Folder Id \
&) MnDOT-printerTabloid(11 z 17in).pitcfg MnDOT-printerTabl.. MnDOT-printerTabl... 73491
(L1} MnDOT-printer36z600.pltcfg MnDOT-printer36z.. MnDOT-printer36z... 734N
1) MnDOT-printer11z17.pltcfg MnDOT-printer11z.. MnDOT-printer11z... 73491
I Y MnDOT-printer11Z17 (2).pitcfg MnDOT-printer11Z.. MnDOT-printer11Z... 73491
3 ) MnDOT-printer11inz17in.pltcfg MnDOT-printer11in.. MnDOT-printer11in... 73491
& Y MnDOT-printer.pltcfg MnDOT-printer.pitc.. MnDOT-printer.plitc... 73491
) MnDOT-pdf pitcfg MnDOT-pdf pltcfg MnDOT-pdf.pitcfg 73491
| pitcfg f Mni f-wms.p 7349
[ ) MnDOT-pdi-Nolayers.pltcfg MnDOT-pdf-Nolay.. MnDOT-pdf-NolLay.. 73491
Address: pw:\\Alliant-FS2.alliant-inc. _20180323\DOT_MICRO\pltcfg\MnDOT-pdf-wms. pltcfg v !
Description: MnDOT-pdf-wms.pitcfg ‘
File Name: MnDOT-pdf-wms. pltefg ‘
All ~
Extension: Printer Driver Configuration Files [*.pltcfg; *.pit] =
[_]open document as read-only
Open Cancel

Project\Wise

Yes Mo

f) To printin color, set the ‘Color:’ choice to ‘True Color'.

Document MnDOT-pdf-wms.pltcfg is read only. Would you like to
open it anyway?
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=

BYHED
General Settings

Area:  View

“ Print (MnDOT-pdf.pltcfg)
File Settings Resymbolization

Copees: |1
Grayscale
Printer
Bentley driver * g
Paper] Roll - 36" x 60" v
Paper size: | 60.000 36000 in

Landscape ¥ Create plot file ~
Show design in preview A .
Print Scale and Position
Scale: | 128.6357 g 1 in. (papear) to 128.6357 ' (design)
Size: (56738 (36000 |in  H Maximize Rotaon: None ¥
Ongin: | 1.631 0.000 in. Auto-center
i
Print Resymbaolization
Pen table:  c\pw_working\projectwmse\alliantidms4808 Nalliant_bw tbl 9 x
Design script: q x

g) To printin color, while still in the ‘Print’ window, go to the ‘Print Resymbolization’ section in the
bottom and click the magnifying lens. Select ‘alliant_color_final.tbl” and click ‘Open’
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B Select Pen Table File X
Select
Folder
= plotdrv vie Bl EEIR
0o v\
Document
Name Description File Name Folder Id \
1) alliant_MplsWater.tbl alliant_MplsWater.t.. alliant_MplsWater.t... 48087
[ Y alliant_MplsStreet.tbl alliant_MplsStreett.. alliant_MplsStreet.t.. 48087
[ Y alliant_MplsStreet-final.tbl alliant_MplsStreet-f... alliant_MplsStreet-f... 48087
) alliant_MplsSewer.tbl alliant_MpilsS t.. alliant_MplisSewer.t... 48087
J88R 5 lliant_color_final.tb g J alliant_color _fir
) alliant_color.tbl alliant_color alliant_color.tbl 48087
alliant_bw_MSP.tbl Alliant Pen Table - ...  alliant_bw_MSP.tbl 48087
7 alliant_bw_final.tbl alliant_bw_final alliant_bw_final.tbl 48087
) alliant_bw.tbl alliant_bw alliant_bw.tbl 48087
Address: pw:\\Alliant-FS2.alli kspace’ Alliant\AEI_MICROplotdrv\alliant_color_final.tbl vj
Description: alliant_color_final
File Name: alliant_color_final.tbl
Agplication: All Applications v
Extension: Pen Table Files [*.tbl;.cth; *.stb] 2
[CJopen document as read-only
ance

h) A warning might appear “Document alliant_color_final.tbl is read only. Would you like to open it
anyway?” Click ‘Yes'.

ProjectWise

Document alliant_color_final.tbl is read only. Would you like to open it
amyway?

e

i) Inthe Print dialog box, go to the Settings tab>Raster Options

Bt Print (MnDOT-pdf-wms.pltcfg)
File | Settings | Resymbolization

é (  Units » 1
| Update from View
| Set Fence from Fit All )
AN catFencufon FRMester | nand
Vi< Apply Print Style
Coll Print Attributes [
| Print Levels/References
..... | Raster Options
LB% PDF Property Filter.
papi 2D Plotting v
Popd Visible Edges Settings
| Preferences

Lm*—'crm*
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i) Change the raster quality factor to 30. This should keep the printed pdf file size down and prevent
the error where the WMS server is not able to display data at certain (higher) resolutions.

Print - Raster Options
General
[ ] Print raster images
Raster Color

|—] Print raster in grayscale

|:| Print monochrome raster as-is

Brnghtness: 0O -100 < > 100

Contrast: 0 -100 < > 100

Raster Qualit
IOqulryfuclnr 30 I 1< > 100

Printer resolution (dpi): 75

Raster resolution (dpi): 22
e

k) While in the ‘Print’ window, select ‘Print’ from the ‘File’ dropdown menu. The ‘Select a Wizard’
will appear. Choose ‘No Wizard’ and select ‘OK’.
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Bt Print (MnDOT-pdf-wms.pltcfg) — X

File | Settings Resymbolization
Open Print Definition File.. 4
Save Print Definition File..

Configure Windows Printer sterizod
Preview
| Print..

Select Windows Printer
Select Bentley Driver

Edit Printer Driver Configuration
Reload Printer Dniver Configuration

Exit

Paper size:  17.000 11.000 in
Landscape ¥ Create plot file ¥

Show design in preview A .

Print Scale and Position
Scale: 4293284 R 1in. (paper) to 429.3284 ' (design)

Size: | 17.000 10.786 in. i] Maximize Rotation: None 2
Ongin: | 0.000 0.107 in. Auto-genler
Print Resymbolization

Pen table: __\Standards\Alliant\AEI_MICRO\plotdrv\alliant_color_final tbi QX
Design script: QX

& Select a Wizard > ‘

Document Creation Wizards II'

Cancel

Mo Wizard Advanced
Wizard

[ IMake this wizard the default

[) Inthe ‘Save Print As’ window, navigate to a folder using the ‘Select’ button in the ‘Folder’ section.
Set the name in the ‘Document’ section under name. Set the ‘Format’ to *.pdf. The ‘Application
should default to ‘Bluebean?’, if it does not, choose it from the ‘Application’ menu.

m) Your document will save as a .pdf file. Open the .pdf file and print in a .pdf-reading software such
as Revu. Congrats, you have created a WMS Aerial and Learned how to Print it.
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File Edit View Document Batch
™ New PDF -

New PDF from Template

Ctri+0

Ctri+F4

Shift+W

Ctri+Shift+S

Pul

& Email Ctri+E
Email Templates
Export

Print Ctri+P 5
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